You must log in or register to comment.
Creating functions is IMO not the first thing you should do. Giving variables better names or naming temporaries/intermediate steps is often all you really need to do to make things clearer. Creating smaller functions tends to be my last resort and I would avoid it when I can as splitting the code up can make things harder to understand as you have to jump around more often.
I hear ya. As always, it’s a balance between having functions that are too long, and many too small functions. Matter of team preferences too.